相關文章

55b43326eb152cfd0e305cd5f12df393 2004年底問世的Sony PlayStation Portable在歡慶10歲生日之後,Sony不冷不防地釋出6.61版韌體更新,讓人玩味的是,PlayStation Portable早以退出主流遊戲主機市場,前一次韌體更新是在3年半前,而且它早在2014年6月就已停產。依照慣例,此類更新大概是為了修補破解漏洞,但開發者The_Z表示破解沒有問題。

詭異的韌體更新

PlayStation Portable是第一台具有韌體更新功能,且真的有活用該功能的主流遊戲主機。更新韌體除了可以讓主機獲得新功能之外,對於廠商來說,更重要的是能夠封堵破解漏洞,增進系統的安全性,也可以避免遊戲軟體受非法盜版行為侵害。縱觀過去Sony所提出的官方韌體更新說明,只要看到「已改善了使用部分機能時系統軟件的穩定性」,就知道改善部分是將破解漏洞修補起來。

Sony於2015年1月15日釋出的6.61版韌體更新,其更新的主要機能也是修補漏洞,不過讓人感到意外的是,距離上次6.60版韌體更新釋出的2011年8月10日已經超過3年,如果真的是要修補漏洞,時間不應拖這麼久。此外,PlayStation Portable已經幾乎沒有新遊戲推出,主機硬體也已停產,在這個時機點推出更新的用意讓人不解。

▲6.61版韌體更新的變更只有「已改善了使用部分機能時系統軟件的穩定性」。

▲6.60版與6.61版韌體更新日期超過3年,時間點非常詭異。

洞?沒有補起來啊

有謠傳指出,促成系統更新的主因,或許就是星間遊俠黑暗再臨(Brandish -The Dark Revenant-)這款遊戲。由於它在PlayStation Network商店推出適用於PlayStation Vita/Vita TV、PlayStation Portable Go的版本,並要求需要PlayStation Vita更新至3.36版韌體以上、PlayStation Portable更新至6.61版韌體以上,增添了傳聞的可信度。

在The_Z進行的初步測試中,他發現6.61版韌體並沒有封鎖,以往透過Fake_np與Sign_np自行進行數位簽署的自製程式與遊戲,還是能在6.61版韌體中運作,不過ME、LME、Pro等自製韌體,以及HEN程式啟動器與降級程式,則是因為執行時會檢查系統韌體版本,所以會阻擋6.61版韌體,簡單地修改一下程式或許就能解決問題。

在經過幾天的檢視後,The_Z並沒有發現6.61版韌體修補了任何漏洞,能在6.60版中執行的經自行簽署的自製程式與遊戲,在6.61版中也沒有問題。雖然目前還沒有自製韌體與降級程式,但是他相信這2個版本韌體的差異很小,所以這些破解工具應該能輕易移植到6.61版韌體的環境中。

The_Z表示目前已經知道可以透過一些技巧,在型號為PSP-1000與非採用TA-88V3主機板的PSP-2000主機上,安裝cIPL自製韌體,雖然自製韌體還無法完整使用全部功能,但是各款自製韌體應該都在進行更新工作中,應用不久後就會正式發布。另一方面,降級程式的工作則還不明朗,但是真的有人需要把6.61版降級到6.60或更早的版本嗎?照目前的情況來看,應該是不需要啦。

▲或許星間遊俠黑暗再臨在部分主機的相容性問題,是6.61版更新的主要原因。(圖片來源:Falcom

▲目前6.60版自製韌體已經相安無事過了3年多,有人會想要升級到6.61版韌體嗎?

延伸閱讀:

家用主機秘辛09:大門忘記上鎖的PSP

駭客大暴走之後,VHBL掛點 、ARK更新

PSV破解風波後續:封殺已公開漏洞,未公開進度也遭波及

使用 Facebook 留言

勞碌命
1.  勞碌命 (發表於 2015年1月20日 13:54)
是不是單純只是為了PSN啊?
Sony前陣子被駭的厲害, 說實在現在也沒有必要去封鎖早已過了生命周期的產品,這樣搞不好成本還太高

發表回應

謹慎發言,尊重彼此。按此展開留言規則